支付宝的 SDK 就这么坑人的吗

https://developer.aliyun.com/ask/285113
第一次对接支付宝的接口,用的官方最新版 PHP SDK,然后遇到了跟这个提问的一样的错误:无效支付宝根证书
然后我根据这个答主的说法把 SDK 里 hex2dec 方法里的 return round($dec, 0); 改成 return $dec; 就不报错了
答主用的 sdk 版本是 php-4.9.1,我的是 4.9.2,他 7 月 7 号回答的,现在已经过去两个多月了

相关文章

8 thoughts on “支付宝的 SDK 就这么坑人的吗

  1. PHP 版资源

    环境要求:
    适用于 PHP 5.5 以上的开发环境

    =========

    我觉得写的已经很清楚了

  2. 我说的是支付宝给的 SDK 的版本,是昨天才在官网下载的最新版;我用的 PHP 版本是 7.0 以上
    @justrand #1
    @tabris17 #3
    @luhe #4

  3. 讲真,微信小程序也经常遇到一些疑难杂症,全网搜索,就官方社区有一样的情况,但满屏都是,我也一样,你们解决了吗,之类的,更绝望,有的时候还是 V 站靠谱

  4. 我以前接的时候,是感觉微信的 SDK 贼烦,怀疑是实习生写的,里面居然还有代码截图,然后目录层级也很混乱。当时感觉支付宝的体验比微信好多了。

发表评论

电子邮件地址不会被公开。 必填项已用*标注