有人在用基于 python2.7 的 moinmoinwiki 吗?

在用 dokuwiki,总是觉得有点不方便,于是使用 dokuwiki 。

用 python3.7 运行 moin/wikiserver.py , 报错:

py2.jpg

看这个语法问题,应该是要用 python2 运行而不能用 python3 。在 http://www.moinmo.in/HelpOnUpdatingPython 里提到 The default installation process (setup.py) installed the MoinMoin files into the site-packages directory of the current Python installation (for example /usr/lib/python2.4/site-packages).

隔壁 dokuwiki 用 php7,页面顶部有报错误信息,好像除了偶尔丢失编辑工具栏的图标之外没有大的 bug 。最新版本是 2018 年发布的。而 moinmoinwiki 也是 2018 年发布。看网上好像没什么人推荐用 python2.X 了,好奇我还应该转用 moinmoinwiki 吗?

相关文章

2 thoughts on “有人在用基于 python2.7 的 moinmoinwiki 吗?

  1. except ValueError, e: was the syntax used for what is normally written as except ValueError as e: in modern Python (described below). The old syntax is still supported for backwards compatibility

  2. 更新一下:

    1 、“在用 dokuwiki,总是觉得有点不方便,于是使用 dokuwiki 。”改为:于是试用 moinwiki 。

    2 、dokuwiki 运行在 php7.3 上,目前没发现任何问题。

发表评论

电子邮件地址不会被公开。 必填项已用*标注