apache 多 PHP 版本共存的问题

一台很老的服务器了不太能大幅改动这只能在现有基础上改一改,之前的 php 版本是 php5.3,现在需要部署一个 php7.2 版本的项目上去遇到了共存的困难

http.conf 部分

<IfModule prefork.c>
  LoadModule php5_module modules/libphp5.so
</IfModule>
<IfModule worker.c>
  LoadModule php5_module modules/libphp5-zts.so
</IfModule>
AddHandler php5-script .php
AddType text/html .php
DirectoryIndex index.php
<VirtualHost *:80>
Serveralias example1.com
</VirtualHost>
<VirtualHost *:80>
Serveralias example2.com
</VirtualHost>

是这么个结构(实际上 virtualhost 是 include 的,我给写一起了)

LoadModule php7_module modules/libphp7.so

现在只要如上一 load php7 就无法启动

/bin/bash: line 1:  5667 Segmentation fault      /usr/sbin/httpd

应该是 https://bugs.php.net/bug.php?id=70380 这里提到的不能同时 load5 和 7

于是现在就遇到问题了,怎么多版本共存,搜索了一天了也没能找到可以使用的方法,求教

相关文章

2 thoughts on “apache 多 PHP 版本共存的问题

  1. @127000 我想起来了之前看到了因为 glibc 过低就没用

    然后我现在升级了。。。用的 sudoer 账号而不是 root,现在系统崩了。。。让我自闭一会。。。

    不过还是感谢的

发表评论

电子邮件地址不会被公开。 必填项已用*标注